Tiny Tiny RSS: Community

Ttrss not rendering properly, missing css

i can suggest checking in browser F12 console (network tab) for errors related to CSS files, then check your http server logs for errors (also related to CSS files) and go from there.

do all that in a clean browser profile, without addons, or an incognito window to exclude addons like adblock blocking parts of tt-rss by mistake.

i have no idea what “Caddy” even is so i can’t really help you with it specifically.

also, try doing view source on tt-rss index page and post <link> elements related to CSS, i.e.

<link rel="stylesheet" id="theme_css" type="text/css" href="css/default.css?1553831585"/>

login page should also reference css/default.css which you should be able to open in browser, btw.

Caddy is an alternative for nginx, i like it gives automatic https using LetsEncrypt which works nicely for my other sites.

I tried developer console on the browser incognito window, no errors just two warnings on dojo.js and common.js about some deprecation.

Do you know where would be the http logs and how can i check them?

It’s not loading CSS, how can there by nothing in the inspector? In most browser’s the inspector has a Network tab. Click that, then refresh the page and look for errors in the requests.

switch to console network tab and reload tt-rss, if CSS files are not loaded you’ll see the errors in the output.

05aOHjQj

alternatively try to open (tt-rss)/css/default.css and (tt-rss)/lib/flat-ttrss/flat_combined.css in your browser.

view source has this css link
<link rel=“stylesheet” type=“text/css” href=“css/default.css?1557255136”/>

and yes i can browse to css/default.css

Do you have Caddy provide a Content Security Policy header?

like i said above, you should investigate network tab of F12 console for any reported errors.

also, check this ^

Here is the screenshot, i see default.css

default.css and flat_combined.css opens fine in the browser

well it’s visible that default.css loads properly (200 OK).

try a different browser, if you haven’t yet. otherwise i’m afraid i’m out of ideas.

e: you can also PM me your tt-rss URL.

Use Nginx. :man_shrugging:

i’m not convinced this is server-related, it seems to serve files just fine. it looks more like a frontend issue of some kind.

not sure how i do that, i am google that now, if you know please let me know. thanks.

you can check all request and response headers in chrome console network tab, select any requested URL and you’ll see it.

Can’t go back to Nginx, I already setup few sites and all working well.

I could give a try and install on another raspberry Pi with just apache

If you don’t know how, then you probably didn’t set it. It wouldn’t make sense for that to be a default in a web server. Besides, the inspector would have reported a CSP violation.

This really feels like you have an adblock that runs even in incognito, or perhaps browser-based user-defined CSS that’s messing with this. Heck, you might even have anti-virus/malware that’s breaking it.

I do agree. Though it’s weird that it worked with Apache and not now.

post your tt-rss URL here or via PM, so we could take a look at your login page.

well, i’ve checked the URL you sent me and you need to pay more attention to developer console warnings. allow me to quote:

Resource interpreted as Stylesheet but transferred with MIME type text/html

you need to set proper mime content-type for css files. looks like this was a server configuration problem after all.

Thank you both for really helping me out yesterday to resolve my tt-rss css issue. Fox thanks for taking time and pointing out the error. Immediately after i googled and found the way to set MIME type in caddy and all worked and i was so happy to see my screen back (was really fiddling with this for a few days).

I couldn’t respond back yesterday becaz the site said i reached the max limit of response and need to wait 24hrs.

A post was split to a new topic: Update.php Permission Denied Error