Tiny Tiny RSS: Community

Ttrss not rendering properly, missing css

I was using ttrss for a while, don’t know what happen and when now its all messed up.

  • at the login screen i enter username/password (screen looks fine what its suppose to be)
  • after logged in i can see text only, and no css applied, hard to read anything, i can see all my feed and counts refreshing.

Now i removed nginx and apache2 and setup caddy and it works fine with other websites i had setup.

I tried update tt-rss by git pull and also manually copy files and nothing worked.

I am ready to loose my current feeds if i can setup a fresh tt-rss install.

please help. thanks.

No experience with Caddy. I’d recommend Nginx.

Still if assets are not loading then probably the paths Caddy is serving from are incorrect. So view the logs and web inspector to see which files are failing and then make sure those are available. If they report 404s it’s probably just an issue with the paths, if it’s 403 or something it’s probably because the server is matching against some kind of restriction, etc.

Here is a screenshot

TLDR: check for any non-git files in themes & themes.local, remove them

specifically there shouldn’t be files named default.php or default.css

say hello to the FAQ entry

I had looked that before and did not help in my case, still troubleshooting what went wrong.

I deleted the tt-rss folder from /var/www/
and trying to clone from git and i get error repository not found (unfortunately i not able to post links here)

whats the correct url?

nevermind i got the git url from fox / tt-rss

after cloned, then moved my backed up config.php to the tt-rss folder, i ran tt-rss from web ui and it told me to chmod five different folders within, i did that. now back to login screen and the login screen itself not have css applied.

what am I missing?

Also checked caddy log and i don’t see any error yet.

i can suggest checking in browser F12 console (network tab) for errors related to CSS files, then check your http server logs for errors (also related to CSS files) and go from there.

do all that in a clean browser profile, without addons, or an incognito window to exclude addons like adblock blocking parts of tt-rss by mistake.

i have no idea what “Caddy” even is so i can’t really help you with it specifically.

also, try doing view source on tt-rss index page and post <link> elements related to CSS, i.e.

<link rel="stylesheet" id="theme_css" type="text/css" href="css/default.css?1553831585"/>

login page should also reference css/default.css which you should be able to open in browser, btw.

Caddy is an alternative for nginx, i like it gives automatic https using LetsEncrypt which works nicely for my other sites.

I tried developer console on the browser incognito window, no errors just two warnings on dojo.js and common.js about some deprecation.

Do you know where would be the http logs and how can i check them?

It’s not loading CSS, how can there by nothing in the inspector? In most browser’s the inspector has a Network tab. Click that, then refresh the page and look for errors in the requests.

switch to console network tab and reload tt-rss, if CSS files are not loaded you’ll see the errors in the output.


alternatively try to open (tt-rss)/css/default.css and (tt-rss)/lib/flat-ttrss/flat_combined.css in your browser.

view source has this css link
<link rel=“stylesheet” type=“text/css” href=“css/default.css?1557255136”/>

and yes i can browse to css/default.css

Do you have Caddy provide a Content Security Policy header?

like i said above, you should investigate network tab of F12 console for any reported errors.

also, check this ^

Here is the screenshot, i see default.css

default.css and flat_combined.css opens fine in the browser

well it’s visible that default.css loads properly (200 OK).

try a different browser, if you haven’t yet. otherwise i’m afraid i’m out of ideas.

e: you can also PM me your tt-rss URL.

Use Nginx. :man_shrugging:

i’m not convinced this is server-related, it seems to serve files just fine. it looks more like a frontend issue of some kind.