Tiny Tiny RSS: Community

[SOLVED] Upgrade broke tt-rss

PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

Describe the problem you’re having:

After upgrading and signing in as admin, just pulls up a blank page.

If possible include steps to reproduce the problem:

git pull

login using admin account

tt-rss version (including git commit id):


Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Centos 7, PHP 7.0 (IUS), 5.5.60-MariaDB

Please provide any additional information below:

It has been quite a while since I upgraded so there may have been cumulative changes that the upgrade could not handle.

Happy to provide any logs/diagnostics that would be useful.

Did you run any “./update.php --update-schema” ?

I don’t know what happened there, but it works fine here.

If it’s been “quite a while” then you also might need to update config.php with any missing constants.

That being said, TT-RSS should tell you some of this (both the database update and missing config constants). That you are getting a blank screen means there’s a fatal error so check your PHP logs. If necessary change the LOG_DESTINATION to an empty string in config.php so it logs it to a file on the server.

@Athanasius: Thanks for the suggestion. Ran from the command line without any noticeable problems but still not working.

@JustAMacUser: Looking at the logs was a good suggestion. It shows:

 Legacy connect requested to mysql

Any ideas?

Yeah, install the MySQL PDO extension for PHP:

yum install php-pdo-or-whatever-it-is-called

I don’t use CentOS so I don’t know exactly what the package is named.

e: PDO was introduced into TT-RSS late last year.

It appears to be installed:

Installed Packages
Name        : php70u-pdo
Arch        : x86_64
Version     : 7.0.32
Release     : 1.ius.centos7
Size        : 382 k
Repo        : installed
From repo   : ius
Summary     : A database access abstraction module for PHP applications
URL         : http://www.php.net/
License     : PHP
Description : The php-pdo package contains a dynamic shared object that will add
            : a database access abstraction layer to PHP.  This module provides
            : a common interface for accessing MySQL, PostgreSQL or other
            : databases.

Is it enabled in php.ini? Check the thread I linked to earlier; I think fox created a test script to check this.

The test file is gone (i.e., a 404) but pdo seems to be enabled:

; If mysqlnd is used: Number of cache slots for the internal result set cache
; http://php.net/pdo_mysql.cache_size
pdo_mysql.cache_size = 2000

; Default socket name for local MySQL connects.  If empty, uses the built-in
; MySQL defaults.
; http://php.net/pdo_mysql.default-socket

white screen

check your httpd error.log, post everything related

Thanks – looked at the error log and noticed that at some point during my tinkering, the group on my config.php file was changed. Fixed it and everything is working. But I think one of the earlier suggestions likely had something to do with the fix. Many thanks!