Tiny Tiny RSS: Community

Self_url_path problem after WiFi disconnection

I am running TT-RSS in a Raspberry since two months and I had no problem. Today, I had a problem with the router that gives signal to the Rasp, and it disconnected for some hours.

After recovery, I cannot enter into the app and I receive the following message:

Startup failed
Please set SELF_URL_PATH to the correct value detected for your server: 

I didn’t touch anything in config.php till then. The original code was written as: define(‘SELF_URL_PATH’, ‘myDNS/tt-rss’); but when I try to navigate to myDNS/tt-rss cannot connect. When I leave define(‘SELF_URL_PATH’, 'http:// 127.0.0.1/tt-rss/ '); I can connect to the app without problem. It seems that I cannot connect from outside the Raspberry. I have Apache web server.

I tried to add the code define(’_SKIP_SELF_URL_PATH_CHECKS’, true);, but nothing happens and now it’s commented. Can anybody guess what can I do?

no

no, no, no

i suggest switching to feedly

since we repeatedly get people here who can’t figure out how SELF_URL_PATH works (a new low for our little community) i’ve updated description of this option to make it a bit more clear:

thoughts are welcome

got it. My dynamic IP changed, and I had to change my DynDNS. That was the problem, but TT-RSS notified me self_url_path problem. Now works.

Thanks for the attention.

You were serving something on your LAN without a static IP? Find the MAC address for your Pi’s network interface and add an entry on your router’s appropriate page so the router itself assigns the same IP to the device every time.

Also, moving the thread to Unsupported because…

It’s pretty clear. My gosh if you have to make it any more explicit I’m going to weep for society… :slightly_frowning_face: