Tiny Tiny RSS: Community

Remove Label assignment not working

Seem like after you assign a label to a feed, I am unable to remove label, but its not consistent and there are few time it worked.

This is a problem I see only when the labeling is done by the filter i setup.
Very simple filter: If “xyz” text found in content label them as “myXyz”

As a test i assign a label to a feed manually by myself, then few min later i remove the label manually and it works fine.

What could be the issue?
I am running version v19.2 and also have Feedly theme applied.

first of all, you can’t assign labels to feeds. you assign them to articles.

try to find any logged errors. i made a filter that assigns custom labels and i had no troubles manually removing them afterwards, you will need to provide more information somehow.

the mechanism which assigns labels should be the same whether its filters or manual request so i’m not sure what could be the problem here.

my bad yes label it to the article.

i checked errors and its clear.

i have to try figure out to reproduce, may be i can delete the filter and create another one and try the outcome.

thanks anyway

as usual, check for anything unusual in browser error console.

Sometime i wonder if the daemon process that update feeds is marking the labels again and again

it’s a possibility. filters only run when article is updated (i.e. stored hash changes) or new article is imported.

if you have feeds which continuously update - for example changing timestamps or article content then filter might run again and again. in this case i’m afraid this is working as designed.

I checked the console for errors, there was 7, i doubt if its related.

After i hit F5 no errors.

Use the Network tab and check the Response from the according request to backend.php for errors as seen below.

your tool looks different then what i see on my chrome, i see Network but not the POST url like you have, each items tab in your tool have icons, not on mine. what are you using?

The screenshot is from Firefox. In Chrome just look for XHR requests.

when i try the action to remove label and i see 2 entries for backend.php, all 2 status code: 200 and the response text for 2 of them is here, nothing like you showed me. I tried multiple times and all the time it produces 2 backend.php calls and the response is pretty same

{"counters":[{"id":"global-unread","counter":174},{"id":"subscribed-feeds","counter":19},{"id":0,"counter":0,"auxcounter":0},{"id":-1,"counter":0,"auxcounter":58},{"id":-2,"counter":0,"auxcounter":0},{"id":-3,"counter":174,"auxcounter":0},{"id":-4,"counter":174,"auxcounter":0},{"id":-1026,"counter":0,"auxcounter":6},{"id":-1027,"counter":0,"auxcounter":13},{"id":-1030,"counter":0,"auxcounter":3},{"id":"3","updated":"10:04","counter":50,"has_img":1557267983},{"id":"4","updated":"10:06","counter":58,"has_img":1557268007},{"id":"5","updated":"10:06","counter":0,"has_img":1557268014},{"id":"6","updated":"10:06","counter":3,"has_img":1557268018},{"id":"7","updated":"10:06","counter":10,"has_img":0},{"id":"8","updated":"10:06","counter":2,"has_img":1557329506},{"id":"10","updated":"10:04","counter":2,"has_img":1557267937},{"id":"11","updated":"10:04","counter":25,"has_img":0},{"id":"12","updated":"10:04","counter":13,"has_img":1557267950},{"id":"19","updated":"10:04","counter":2,"has_img":1557267953},{"id":"22","updated":"10:04","counter":0,"has_img":1557267957},{"id":"23","updated":"10:04","counter":1,"has_img":1557267959},{"id":"25","updated":"10:04","counter":0,"has_img":1557267975},{"id":"29","updated":"10:04","counter":0,"has_img":1557267979},{"id":"31","updated":"10:04","counter":0,"has_img":1557267988},{"id":"33","updated":"10:04","counter":8,"has_img":1557267992},{"id":"34","updated":"10:04","counter":0,"has_img":1557267997},{"id":"35","updated":"10:04","counter":0,"has_img":1557268001},{"id":"36","updated":"10:06","counter":0,"has_img":1557268005},{"id":-2,"kind":"cat","counter":"0"},{"id":1,"kind":"cat","counter":108},{"id":2,"kind":"cat","counter":0},{"id":3,"kind":"cat","counter":17},{"id":4,"kind":"cat","counter":25},{"id":5,"kind":"cat","counter":13},{"id":6,"kind":"cat","counter":0},{"id":7,"kind":"cat","counter":0},{"id":8,"kind":"cat","counter":2},{"id":11,"kind":"cat","counter":0},{"id":12,"kind":"cat","counter":1},{"id":13,"kind":"cat","counter":0},{"id":14,"kind":"cat","counter":8},{"id":15,"kind":"cat","counter":0},{"id":16,"kind":"cat","counter":0},{"id":0,"kind":"cat","counter":0}],"seq":1307}
next one is
{"info-for-headlines":[{"id":"185507","labels":""}],"message":"UPDATE_COUNTERS"}