Tiny Tiny RSS: Community

ReferenceError: can't access lexical declaration `Headlines' before initialization

Describe the problem you’re having:

After upgrade from v19.2 (9804e3a) to v20.06-68dee9117 got this errors, when login

[email protected]://domain.tld/js/App.js?1592140834:711:10
[email protected]://domain.tld/js/App.js?1592140834:483:3
App.init/</<@https://domain.tld/js/App.js?1592140834:605:16
xhrPost/</<[email protected]://domain.tld/js/common.js?1592140834:24:32
Ajax.Request<[email protected]://domain.tld/lib/prototype.js?1485801250:1827:8
Ajax.Request<[email protected]://domain.tld/lib/prototype.js?1485801250:1756:7


Feeds.open/this._viewfeed_wait_timeout</<@https://domain.tld/js/Feeds.js?1592140834:376:6
xhrPost/</<[email protected]://domain.tld/js/common.js?1592140834:24:32
Ajax.Request<[email protected]://domain.tld/lib/prototype.js?1485801250:1827:8
Ajax.Request<[email protected]://domain.tld/lib/prototype.js?1485801250:1756:7

If possible include steps to reproduce the problem:

  • Login to https ://srv.tt-rss.org/tt-rss/ through firefox 25.9.0 with demo / demo
  • You will get this error.

tt-rss version (including git commit id):

v20.06-68dee9117

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

vds:
Centos 8
php 7.4.7
Postgresql 12.1

Please provide any additional information below:

Firefox 52.9.0

Сhecked in firefox 68 and chrome 83.0.4103.97
The error does not appear.

Can I assume that firefox 52.9 is no longer supported in the tt-rss?

yes.

20charRrRrRrrrrrr

Out of curiosity why would you be using such an out of date browser?

Browser usage is quite uncomfortable without xul-extensions.

I restored the older version of tt-rss from backup. Problem solved.

I know a fair amount of people switched to the pale moon browser to keep somewhat up-to date and have xul extensions. Perhaps you should look into that?

Thank you, I know about this browser.
Only few persons develops it. It does not inspire confidence in the future of this project. Maybe someday I will try this browser.
I think this is offtopic

Wow, a really bad surprise after update. Is there a chance to fix this without updating the browser?
ps, please, add message to the commit about future critical changes, thx

tt-rss software requirements are stated on tt-rss.org frontpage. i’m fairly certain that whatever ancient shitware you’re using - by your own choice - instead of a web browser is not listed there. at least you get to enjoy your unpatched CVEs while everyone leaves you behind.

also, you get to enjoy your permanent ban. fuck off of my forum and don’t come back, luddite.