Tiny Tiny RSS: Community

Published articles feed fails W3C validation

Hi all.

I’m attempting to setup IFTTT to get articles I add to Published feeds and the IFTTT action keeps failing. Following IFTTT’s support I entered the feed URL into the W3C Feed Validation Service. Doing so reports back that the feed is invalid…

This feed does not validate.
Server returned HTTP Error 403: Forbidden [help]

line 1, column 0: XML parsing error: :1:0: no element found [help]

In addition, interoperability with the widest range of feed readers could be improved by implementing the following recommendation.
Feeds should not be served with the “text/html” media type [help]

tt-rss version (including git commit id):
v20.01-47135160d

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Linux 4.19.66-v7+ armv7l
PHP 7.0.33-0+deb9u6
mysql Ver 15.1 Distrib 10.1.38-MariaDB

The feed parses feedcake/myfeedsucks successfully and I’m unable to debug the feed.

I’ve tried generating a new URL but this has not changed the validation failure. The URL from Preferences --> “Published & shared articles / Generated feeds” also fails. Both URLs open fine in a web browser, the only issue is that there is an https error about not all contents being secure. I’m not convinced that that is the issue. Is there something I’ve missed?

I’d prefer to not post the URL at this stage. If it’s really needed then I will do so. Any help would be greatly appreciated.

Thanks,
Shannon

403 means your server is rejecting the request. Since the feed validates with other tools you need to figure out why some requests are being rejected.

You posted in unsupported, if you’re on shared hosting talk to your provider. If you run the server yourself check your web server conf files.

Thanks, good to know its nothing on the tt-rss side, but I’m still a little confused given that when I enter the URL in any browser it loads fine so I don’t get how the validator is the only site giving me a 403.

Just looked that the apache2 error log in debug mode and found “SSL virtual host for servername hostname found” so I might look into that.

Cheers