Tiny Tiny RSS: Community

Google Chrome Autofilling things and causing issues [Solved]

PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

Describe the problem you’re having:

Every time I open an editable element the current text in the field is getting replaced with an old element entered previously by Chrome’s autofill. Say I right click a feed and hit edit, instead of it being populated with the feed I want to edits data, it has an old feed I have edited data replaced in it by Chrome autofill. This is very annoying as it means I lose everything in the feed, including the URL and name so I have to input it all in again if I want to edit it. There is nothing it seems you can do in Chrome to really resolve this, it sounds like the field needs to disable this mechanism.

If possible include steps to reproduce the problem:

Edit a feed in Chrome that has autofill enabled.

tt-rss version (including git commit id):

17.4 (d29abfa316879b24ac0fdc861865567cc7f0fb57)

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Ubuntu 16.04, PHP, MySQL.

Please provide any additional information below:

If I use Firefox I don’t have this issue, however I like to edit feeds a lot and since Chrome is my primary browser it is tedious to always switch to Firefox.

this sounds like a browser or a profile problem to me. try with a clean profile (without sync), if that helps investigate how to remove that autofill data / report the issue to chrome developers.

I opened a guest profile on Chrome and then went to the site and it looks like the problem does not show up now. So you’re right it may be an issue with my profile, however I do not see a way in Chrome to remove one sites autofill data. It looks more like I have to remove all of it, but maybe I should try that. It’s worth noting this does persist across all my computers (all synced to same Chrome profile though).

Don’t just check Chrome itself. Try disabling some plugins/extensions one-by-one. LastPass was doing it for me.

1 Like

Thank you! That solved it! I didn’t suspect that LastPass would be causing this issue, but I disabled Lastpass and it seems to have resolved the problem!

Out of curiosity how did you resolve the problem? I still want to use Lastpass, I tried adding it to the “Never URL” so that it is not supposed to do anything on the site but it still seems to be doing it.

What I just did was go into the Lastpass settings and disabled the option that was enabled that allows it to fill forms that already have text in them. I don’t want to keep this as a permanent solution so if you have other ideas that would be great!

For those who find this thread in the future also read this from the old forum:

Lastpass is horrible shit that breaks tt-rss

Is it just me, or should fox add “If you’re lusing lastpass, just GTFO,” to the “read this before you post” section?

I actually don’t remember. Sorry.

Probably… issue comes up often enough. :unamused:

Would have avoided me making this post :stuck_out_tongue:

Is it just me, or should fox add “If you’re lusing lastpass, just GTFO,” to the “read this before you post” section?

not a bad idea