Tiny Tiny RSS: Community

Visual Indication When Filter Disabled

Tiny Feature Request:

Some way when you’re looking at the list of Filters to easily show those that are disabled.

At the moment if you hit “inverse” for a filter expression it shows in red. I propose that a Filter that has “Enabled” unticked is shown in strikethru, or a light grey font instead of black.

That’s it. That’s the extent of my idea.

Much Love please don’t murder me @fox.

You can do that yourself; in preferences choose customize theme and add:

div.filterDisabled {
	text-decoration: line-through !important;
}

The magic of css.

(Oh great. Now @fox is going to come after me. Please just take me, spare my family, I didn’t know about CSS!)

Thanks @rodneys_mission, I appreciate the tip. The only problem is, that puts strikethrough the word “filter” for me, not the actual filter item that’s disabled.

I don’t know how to look at the CSS/have any clue, but I assume there’s a typo/word wrong there somewhere?

image

In my screenshot, I want a strikethru on “Auto Read (News)” as I’ve currently disabled it.

Really appreciate the help though.

Joking aside, don’t @ tag people unless you actually need to draw their attention to something specific.

I don’t have TT-RSS in front of me but you can use a web inspector to narrow down the CSS selector.

Fair point re tagging, yes, that’s actually quite a genuine dick move. Sorry.
I’ll check the CSS selector, I don’t know how to use one but I might as well learn.

in stock CSS, disabled fitlters should be light gray (it’s done through opacity though, not color), including action list:

06y3tfYl

the selector you’re looking for is likely .dijitTree .dijitTreeRow.filterDisabled.

Something must be screwy with my install then, using the default theme I and .dijitTreeRow.filterDisabled I still end up with “filter”’ struck-thru and none of the filters.
Even if I remove it, I don’t see it greyed out like in your example.

Anyway, thank you, I’ll have a hack at it.

you’re using an older version, maybe? you haven’t specified. either that or a non stock theme.

No I just did a git pull to ensure I was running the very latest. And yes, I have been using the Feedly 3rd Party theme, but reverting back to stock hasn’t fixed it.
I probably have some lame browser plugin or similar stuffing it up though, or some old css files lying around. I’ll clean it all up and test again. Thanks.

The css rule works here. And fox gave a more specific rule that should work.

Disabled rules should be greyed out per out of the box css; this rule doesn’t look disabled to me.

There must be something in my filters then, or something else, that’s breaking it.
What I’ve just done:

Cloned a whole fresh copy of the tt-rss git repo:

git clone --depth=1 https://git.tt-rss.org/fox/tt-rss.git

Copied only my old config.php (no 3rd party themes/plugins) into the new directory and visited my install and I still see the same.

I will see if I can do some more debugging to narrow down what’s triggering it.

So I’ve created myself a new test account on my TT-RSS Instance.
Still I get the same thing.

What could I be doing wrong here? I thought browser cache, but even a new browser (Edge, shudder) gives the same.

is the filter actually disabled? edit filter, options, uncheck enabled.

I swear!

If anyone wants to test and tell me if I’m crazy:

[Removed Test Details]

There’s two rules, one enabled and one disabled.

this is weird.

  1. root entry (“Filters”) being gray seems like an unrelated bug, i see it on my instance too.
  2. i’ve exported OPML on your instance, made a new user on my test instance, and filters show as disabled properly. :thinking:

e: this is related to mysql so it’s probably a boolean value not handled properly somewhere in the PHP code (pgsql and mysql return those differently because life is suffering). i’ve managed to replicate this.

e2: root being gray is unrelated, fixed thanks to you noticing :slight_smile:

Ahhh, good ol’ mysql.
I do mean one day to convert to pgsql because I know that it’s the “tested” database that everyone’s using.
Thanks for looking at it, I appreciate you took the time.

both of those issues should be now fixed in trunk.

well, having people who actually notice bugs while using mysql is also good for everyone :slight_smile:

Yes! The filters page looks much better now and my disabled filters are greyed out.

Thank you very much! We can close this “feature request” heh.

Thanks all for your help.