Tiny Tiny RSS: Community

Using official Docker with Synology Docker GUI

Hi

Anyone been able to get ttrss up and running using fox’s docker container and the synology docker GUI. I’m basically having to manually carry out all the steps because i can’t use docker-compose. So far I’ve set up the database, created the app container, created the web container and linked them together. I can now run ttrss successfully but the only part missing is updating the feeds.

Am I right in thinking I should set up another ttrss-web container, linking it to the app container and run the updater.sh command on startup?

No doubt Fox will hit his forehead with his palm so i didn’t dare post it anywhere other than unsupported :smile:

I think you’re on the right track, updater uses same image, the only difference is the entrypoint script.

Thanks Fox.
Anyone successfully run this using the Synology GUI?
I’ve tried updater.sh and /src/app/updater.sh for the command but get the following error message

args:2 - Error during parsing: Unknown directive ‘/src/app/updater.sh’

any particular reason you’re doing this through the web gui? i think it would be a lot easier to enable SSH on synology and run docker-compose directly.

Only reason being all my other dozen or so containers were set up through the GUI so that was my starting point. If i don’t manage to get my head round the execution command I’ll try docker-compose.
Appreciate the response

i’ve never even seen this gui but correct script location (inside the container) is /updater.sh.

Hi

Has anyone managed to get the updater up and running on anything other than docker-compose, I’ve played around with Portainer and interestingly (for me anyway) I’m getting the exact same error message using the command /updater.sh (unknown directive)

Is the entry point in docker hub definitely correct as it can’t find the updater script?
Dockerhub
image
Portainer Error
image
Portainer instructions
image

you need to use a separate entrypoint, not pass /updater.sh as an argument to caddy which is what you’re seemingly trying to do.

e: also there’s no /updater.sh in the caddy (web) image.

I feel like an idiot here, I’d created the wrong container for the update container (web rather than app). If anyone is as stupid as I am then this screenshot may help.
Thanks to Fox for showing me some patience

Note that I had to change the execution command entry point to /bin/sh and I also had to link the update container to the db but the docker-compose in dockerhub suggests that the update container is linked to the app only

image

image

If it’s of interest to anyone I’ve now written a blog post from start to finish
https://blog.oliroe.com