Tiny Tiny RSS: Community

Troubleshoot problems updating to last version c0f689a58f

Describe the problem you’re having:

upgrade from tag v19.08 to c0f689a58f

If possible include steps to reproduce the problem:
Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1055 ‘tinytinyrss.f.title’ isn’t in GROUP BY in /var/www/html/tt-rss/classes/counters.php:109 Stack trace: #0 /var/www/html/tt-rss/classes/counters.php(109): PDOStatement->execute(Array) #1 /var/www/html/tt-rss/classes/counters.php(9): Counters::getFeedCounters() #2 /var/www/html/tt-rss/classes/rpc.php(277): Counters::getAllCounters() #3 /var/www/html/tt-rss/backend.php(111): RPC->getAllCounters() #4 {main} thrown

tt-rss version (including git commit id):
c0f689a58f

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Ubuntu 16.04 LTS
PHP 7.0.33
MYSQL
±------------------------±-----------------------------------------------------+
| Variable_name | Value |
±------------------------±-----------------------------------------------------+
| innodb_version | 5.6.45-86.1 |
| protocol_version | 10 |
| slave_type_conversions | |
| tls_version | TLSv1.1,TLSv1.2 |
| version | 5.6.45-86.1 |
| version_comment | Percona Server (GPL), Release 86.1, Revision 5bc37b1 |
| version_compile_machine | x86_64 |
| version_compile_os | debian-linux-gnu |
| version_suffix | |
±------------------------±-----------------------------------------------------+

Please provide any additional information below:

i honestly have no idea what this is but it’s probably incompatible with tt-rss.

if that helps i’m doing all mysql-related testing on mariadb:10.1 docker image. maybe this should be stated on the frontpage.

e: as usual i have to suggest if possible switching to postgres, or preferably to docker-compose deployment.

Percona Server is a port of Mysql by Percona… It should 100% compatible with Mysql…
Postgres is not very well with Chinese character like search not work any more a few years ago.So I stand with Mysql in the end.

well, i’m afraid you won’t be able to use it with tt-rss. since mariadb supports required syntax, you can try using that instead.

Thanks for your help.
I will stay with
a6d314b753d7e79da06c733efd5a96caf9b5f562 now, this version is ok.

If you are knowledgeable enough to go on an unsupported configuration, then you should also be knowledgeable enough to maintain a fork/patch with that line fixed up for your db server. I probably wants all the f.* columns in the group by; everything that isn’t in an aggregate (guessing).

I know what happens here.
for some reason Mysql is required ONLY_FULL_GROUP_BY, this is a default value in 5.7 I believe.
so I disable this feature and it works smooth with last version
mysql> SELECT @@GLOBAL.sql_mode;
±-------------------------------------------------------------------------------------+
| @@GLOBAL.sql_mode |
±-------------------------------------------------------------------------------------+
| NO_AUTO_VALUE_ON_ZERO,STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION |
±-------------------------------------------------------------------------------------+
1 row in set (0.00 sec)

thanks! i never knew this existed. i’ll link this thread in the FAQ.