Tiny Tiny RSS: Community

[SUGGESTION] Make feeds with starred articles more visible

it’s not hard it’s just annoying because you either have a flat list of articles which might need a lot of scrolling down to pick and choose what you need (if it was starred a while ago) or you need to go on an adventure switching view mode to starred and finding the feed you’re interested in. it’s clumsy.

e: with incoming changeset you’d be able to do this:

body.ttrss_main[view-mode="marked"] .Has_Marked {
    color : green ! important;
}

so feeds are highlighted only if you have starred view mode enabled. this could be added to the default stylesheet, i think.

Ok thanks that makes sense. I usually don’t carry a ton of old saved articles so I haven’t had a problem. But I do agree having the feeds highlighted would be good. I don’t know much about stylesheets so I am going to ask. Will the category the feed is in also be highlighted if you don’t have the category expanded? Or will the highlighted feed be buried in the collapsed tree?

017v1JAR

not sure about multiple nested categories though

This is exactly what I was thinking. Thank you for considering it and implementing this so fast.

IMHO, it would be nice, but it is not necessary. The counter on the right of the starred articles category updates, so I have a vague idea of how many are left, even though I do not know how “spread” they are.

That is exactly what I meant, but I am extremely with the latest version.

Again, thanks a lot

Hi Fox,
Not sure if it’s related to this change. But since doing a git pull just now (deefa901a).
The unread counter for nested categories is kind of broken.
NestedUnread

I’ve done all the usual tricks, clear cache, incognito mode, the result is the same.

yep, this should fix it:

thanks for reporting.

Just did a new git pull and it’s indeed working again.
Thanks for the quick fix Fox.

with this changeset feed tree should switch to showing starred counters if view mode is set to starred: https://git.tt-rss.org/fox/tt-rss/commit/60288f02e8947282bf9226f63d0ce052f9c9ac61

this is something that i personally was missing after above changes.

This is elegant and extremely pleasing to watch.

What I believe is missing is a keyboard shortcut (for example f z) or a top menu that would update feed tree with only feeds containing starred articles, either read or unread. It would make managing those articles much more easier.

But as I wrote earlier, I am very happy with the current situation

Thanks again for improving what was already better than before.

Regards

this makes sense but first hiding of categories/feeds would need to be reworked, i’ll make a note to take a look at this.

i think hide read feeds might as well hide feeds with no starred articles when browsing by starred, a separate mode/hotkey seems like unnecessary function bloat.

the option should probably be renamed (or a comment added that notes this behavior)

e: this is now in trunk

I git updated and I am now using v20.02-282b445

Unfortunately “Un/hide read feeds” is broken for me.

I tried using the keyboard’s “f a”, hamburger menu “(un)hide unread feeds” and preferences “hide read feeds” but I am not able to hide read feeds, no matter what I select in the top right menu (unread or starred).

I used Chrome 80.0.3987.116 in regular and incognito mode, and tried with Microsoft Edge, without any difference I could notice. I could try to disable plugins, but I am not sure it has any impact.

Below is browser’s console:

AppBase.js?1582285246:161 keyeventToAction f a => feed_unhide_read
common.js?1544814978:20 xhrPost: {op: “rpc”, method: “setpref”, key: “HIDE_READ_FEEDS”, value: true}
common.js?1544814978:20 xhrPost: {op: “rpc”, method: “getAllCounters”, seq: 7}
AppBase.js?1582285246:161 keyeventToAction f a => feed_unhide_read
common.js?1544814978:20 xhrPost: {op: “rpc”, method: “setpref”, key: “HIDE_READ_FEEDS”, value: false}

The database’s error log is empty.

I am on shared hosting, using PHP 7.2.27 and MariaDB 10.2.31.

Please let me know if I can provide more information.

Regards

Yup, same here. Checking ‘Preferences’ the ‘Hide read feeds’ is still ticked. Tried un-ticking ‘Combined Mode’, no difference. Also, access using ‘chromium-browser -incognito’ same situation. f a keystrokes does nothing. It’s broke.

Edit to add: This is on self-hosted, hard metal, i.e., no docker instance of tt-rss. postgresql 9.5, php 7, …
.

It’s working just fine for me. git clone on Debian, postgresql 12.2, php 7.3.

this is done through CSS now so if you’re using a third-party theme it will need to be updated.

It’s late here and I gotta turn in for the night, BUT I wasn’t using third-party, my theme was set to ‘Default’ when this issue started. I’ve now set the theme to ‘light.css’ and Hide/un-Hide Feeds is working again at commit 282b445 . Thanks for the hint.

OT: At the moment, clicking on any link to a commit like say:

https://git.tt-rss.org/git/tt-rss/commit/282b445a43eaf34f79e946fd2e41bcf96a365fbe

is now redirecting to: https://git.tt-rss.org/install

.

yeah it looks like gogs changed something in their docker container so everything broke when it got updated. really enjoying this shit right now.

these people also seemingly can’t understand a simple concept of version history

the fuck is this shit, what does latest even point to?

reverted to the 0.11.91 (thanks at least for tagging that) so we’re up now, i think.

e: my bad for enabling auto updates for docker stuff, i guess. back to doing this manually.

Yes links to commits AND git pulls are working again. For moment anyway. lol
.

The feedlist is only hidden with light.css, it unhides with compact.css. So I guess not all the CSS files are updated.

you’re running into browser cache issues.