Tiny Tiny RSS: Community

Subscribe to feed gives error "Sorry, an error occurred"

Subscribe to feed gives error “Sorry, an error occurred”
This happens for both the admin user and at least one poweruser account.
There are no entries in the system log when this happens.
This has been going on for a while but I just got around to posting a question about it. My current workaround is to pick my least favourite existing feed and edit it, which works. It also keeps my list short, but I am running out of least favourite feeds to cannibalize…

Solution: I had AdBlock Plus (ABP) running, and it broke adding a feed. Disabling it for this page fixed the problem.

if you actually want help, read the stickies and update your post accordingly.
if “system log” (whatever that is) is empty, try other logs on you server until you find anything relevant.

I am not familiar with discourse or which fork one uses to eat their salad here, so I don’t know what you mean by “read the stickies”. Could you give me a link or be more specific what I am supposed to do?

When I say “system log” I mean the log that is available in the system tab in preferences for admin users. It receives other errors, but nothing when I try to generate a feed. The Apache log is empty, too.

Please read:

And:

And while I appreciate your candor with respect to how things work around here, please know that you will be expected to put some effort into the troubleshooting. In turn, you will get help from others here.

Thank you JustAMacUser. That gave me the hint I needed. It turns out AdBlock Plus breaks adding a feed. I have flagged it with them as a problem, and disabled AdBlock for my TT-RSS page.

Great to hear. Thanks for letting everyone know, it helps people with similar issues in the future.

Just as an aside, try Ublock Origin, it really worked better for me than Adblock Plus, across all browsers.

Thanks for that pointer, tsimmons. I will have a look at uBlock. Had not heard of it before.