Tiny Tiny RSS: Community

SOLVED: Clean feed acording to fakecake creates error " Unknown/unsupported feed type"

PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

Describe the problem you’re having:
I get an “fetch error: Unknown/unsupported feed type” on a lot of my feeds.
One Example: http://www.heise.de/open/news/news-atom.xml
https://fakecake.org/myfeedsucks/ shows no error.
Using curl to download and comparing it with cache/feeds shows no difference.

If possible include steps to reproduce the problem:
Today I updated to the current git version as I do every now and than and updated the schema, after an Backup of course. An now more then 50% of my feeds show this error. I didn’t wrote done the last git commit, so I can not roll back, to the last working commit. But I still have the backup if needed.

tt-rss version (including git commit id):
git master
commit 79c50359203afef9c04824376368040139fc3402
Author: Andrew Dolgov [email protected]
Date: Mon Nov 26 12:44:36 2018 +0300

reset password: use updated mailer parameters properly

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Centos 7.5, php 7.1 from REMI, MariaDB 5.5.60-1.el7_5

Please provide any additional information below:
OUTPUT of ./update.php --debug-feed 26 --force-refetch --force-rehash | tee -a /tmp/debug_output.txt

[20:27:06/28673] Lock: update.lock
[20:27:06/28673] start
[20:27:06/28673] local cache will not be used for this feed
[20:27:06/28673] last unconditional update request: 2018-11-28 18:10:41
[20:27:06/28673] stored last modified for conditional request: Wed, 28 Nov 2018 18:09:06 GMT
[20:27:06/28673] fetching [http://www.heise.de/open/news/news-atom.xml] (force_refetch: 1)…
[20:27:06/28673] fetch done.
[20:27:06/28673] source last modified: Wed, 28 Nov 2018 20:24:40 GMT
[20:27:07/28673] saving cache/feeds/9c317e78e28e1c8642838c777255428395ce2dab.xml
[20:27:07/28673] fetch error: Unknown/unsupported feed type
[20:27:25/28723] Lock: update.lock
[20:27:25/28723] start
[20:27:25/28723] using local cache [cache/feeds/9c317e78e28e1c8642838c777255428395ce2dab.xml].
[20:27:25/28723] fetch error: Unknown/unsupported feed type

Addon 22:00:
I have this installation running since 4 years and no major changes in the last year or so since updating to php7.1
I checked the required php modules they are all installed and I’m not sure if this is enough:
[email protected]: # php71 -i | grep -i xml | grep -i DOM
DOM/XML => enabled
DOM/XML API Version => 20031129

No other php version is installed (anymore since today to make sure that is not the problem).


sorry for the noise. I solved it myself.

My /etc/php-cli.ini had some php-modules included that were already defined. I found it before, but didn’t think it was relevant. I removed it just now and now everything works again. The entries were there since Oct 2017 and were not problem until now.
So always check every single error.

Sorry again for the noice. You can through it into the “Gas Chamber”. :slight_smile: