Tiny Tiny RSS: Community

Save To Wallabag Plugin

I’m trying to get this to work:

and I’m not having any luck at all. Can anyone here confirm it works at all? I don’t know if it’s just too old and I’m wasting my time or if it legitimately works and I’m just not doing something right.

I get the following error when trying to save article to Wallabag:

ReferenceError: Can’t find variable: Notify

This is after I have enabled the plugin and setup my API key/secret combo.

looks like your tt-rss version is too old, you need to update

This plug-in broke for me a while ago , even running while the latest version of tt-rss.
Now I just use the wallabagger Firefox plug-in and right-click on the article title to save to wallabag.

This plugin works for me, in a fairly recent Wallabag and TT-RSS. There is a tt-rss error each time I collect an article, but the article is correctly parsed in Wallabag.

OK , Thanks @Glandos , perhaps I’ll give it another try.

Using the latest version of ttrss from git, and this plugin, I am currently experiencing no issues with the plugin. No errors are thrown and everything works as expected. Please open an issue if you encounter any problems.

Thanks @joshp , I reinstalled the plugin from scratch and it is working perfectly again.

1 Like

edit: Solved! Did not include the /web shown on the end of my domain url. Now everything works! Carry on.

 Alert: No OAuth tokens in Database! Submit Username and Password to retrieve new tokens.

Clicking Save on account credentials returns no notification, as mentioned here[1]. I’ve tried refreshing the page or waiting several minutes, but same result with every attempt.

[1] https://github.com/joshp23/ttrss-to-wallabag-v2/issues/37

Attempting to use the plugin URL results in:

Question: Can I automatically trigger the Wallabag plugin for every item in a specified feed?

I am interested in this too

I’ll look into this when I have time. Pull requests are welcome.