Tiny Tiny RSS: Community

Reeder v4 not working with Fever API

Hi HenryQW,

I just purchased Reeder v4 but it will not login via Fever and my TinyRSS, although Reeder v3 still logs in fine. I noticed that you have an entire Docker for TinyRSS, but I would rather just get my fever pluggin working, then switch everything. Did you make any changes to the Fever Pluggin to get it to work with Reeder V4? I have tried a few forks from 1.4.7 to 2.2 but none allow Reeder v4 to login? It gives no error at all, and I don’t see anything in the TinyRSS system log.

Mod note: I’ve moved this to its own thread because it’s a completely different issue than the thread you originally posted this in. Please start new threads for new issues.


You really need to check the logs: both of the server and on your iOS device.

On your iOS open the Settings app and navigate Privacy > Analytics > Analytics Data and see if there’s anything in there for Reeder 4.

I can confirme the problems with Reeder 4. After installing and connecting TT-RSS three weeks ago(!), Reeder 4 still has pulled only ca. 3000 articles (out of 10.000).

Re-installed Reeder 3, connected TT-RSS, after less than 10 minutes Reeder 3 was done syncing and pulling all articles.

But if it pulled any articles then it must have connected, I cant even get it to accept the connection, but Reeder 3 has no problem. I noticed that Reeder v3 has an option to ignore certificates, so I “suspect” its an SSL cert issue, but just guessing at this point…

Update: yes, thats it … Reeder V4 will not accept self-signed certs, as soon as I switched it to a temp LetsEncrypt it worked.

If you use a certificate that is signed by your own root certificate authority, you can load the root CA’s public certificate in mobile Safari and you’ll be given the option install it. Then in Settings > General > About > Certificate Trust you can enable trust for that certificate.

If Reeder is using the operating system to validate the certificate (probably is) then it will work (you may need to force quit the app and relaunch it).

I’m either doing it wrong, or the problem isn’t SSL exactly. So I got the cert into Trusted, and now if I load the Tiny site in mobile Safari, it does not complain about the cert and takes me straight into TinyRSS, but when I use Reeder v4 it still will not get passed the entering of details.

If Safari is now trusting the site (not giving a certificate error anymore), then you’ve done it right.

If Reeder is still giving an error even though Safari isn’t, then it’s possible the developer is using his own method for validating certificates. I would restart (power off then on) the device just to be sure. If it still fails to work, then send the developer an email with the details.

For me Reeder 4 works just fine, although I do remember having connection issues after the upgrade.

Verify the server address. In tt-rss go to Preferences > Fever Emulation and copy the URL posted there. Then copy that URL to Reeder.

Also, update Reeder to the latest release (4.0.4). There were Fever-related issues in the earlier releases.

Have you added the intermediate certificates to the server? Check your site using ssllabs.com and see if it says “incomplete chain”.

Is your cert self-signed, or something like LetsEncrypt?
I cut and pasted the settings right from reeder 3 into reeder 4 so they are the same/right. I am on the latest 4.0.4 of Reeder. I am on iOS13b2 just in case that “could” be something to do with the trusted cert I tried? I have emailed the dev, we’ll see if he adds self-signing.
I am looking into the scripts for acme and letsencrypt

LetsEncrypt. I remember in Reeder 3 there was a switch for trusting self-signed certificates. In Reeder 4 it’s gone.

And when you go to the Fever plugin’s URL in a browser, you do get API response, don’t you?

tt-rss is on port 411 which ssllabs would not validate. And on 443 I have my exchange server, (which is different cert). This is part of my problem with acme using 80/443/DNS.txt … that I have exchange on 443 so cant use acme,

using the fever url, I get
{“api_version”:3,“auth”:0,“error”:“NOT_LOGGED_IN”}

I suspect strongly its something wrong with my cert and some extra validation. Hopefully he adds the self-cert option back, and/or I figure out if I’m switching/automating letsencrypt

As it should be. No issues here.

Let’s hope!

:face_with_raised_eyebrow:

Try https://www.sslshopper.com/ssl-checker.html , it accepts different ports.

of the 4 checkmarks, the first three are good, but the last is a warning saying that this CA isnt trusted in most web-browsers, which is true cause its self-signed.

Ironically Reeder 4.1 just came out, but sadly a “self-sign” isnt an option yet.

With 4.1, I started from scratch but can’t even sign in anymore - despite a valid letsencrypt certificate (passing all tests on sslshopper.com) and while using Reeder 3 without issue with the same credentials.

I emailed the author about it but no response. There’s no analytics data for Reeder 4 on my device.

Server logs look fine:

Any App alternative on the same level as Reeder?

Tiny Reader is available for iOS and Mac. The developer, @Tiberius, also frequents this forum and is typically pretty responsive to issues/feedback.