Tiny Tiny RSS: Community

Problems Updating to latest version

Describe the problem you’re having:Initial install was on January 9 and everything has been running smoothly since. I last did an update in the past 10 days with no issues. However, attempting to install any update from the past week results in the following error message on the System panel:

Uncaught PDOException: SQLSTATE[42803]: Grouping error: 7 ERROR: column “f.title” must appear in the GROUP BY clause or be used in an aggregate function LINE 2: f.title, ^ in /home/cpanel_user_name/public_html/tt-rss/classes/counters.php:88 Stack trace: #0 /home/cpanel_user_name/public_html/tt-rss/classes/counters.php(88): PDOStatement->execute(Array) #1 /home/cpanel_user_name/public_html/tt-rss/classes/counters.php(9): Counters::getFeedCounters() #2 /home/cpanel_user_name/public_html/tt-rss/classes/rpc.php(277): Counters::getAllCounters() #3 /home/cpanel_user_name/public_html/tt-rss/backend.php(111): RPC->getAllCounters() #4 {main} thrown

All results from the git update command (git pull origin master) appear normal

Could this have to do with being on shared hosting? Anything I can do to fix or further info I can provide?

existing tt-rss version (including git commit id): 20.01-3b29e86

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Namecheap cPanel Linux Shared Hosting - Apache v2.4.41, postgresql, php 7.2.26

post postgresql version.

Version: 8.4.20

Sorry, I know I should have provided that initially.

open tt-rss.org, scroll down, check requirements section.

As soon as I posted the version, I knew that was the issue. Bummer, as I really was liking he performance on postgreSQL. I guess I’ll stay on the current version until I can figure out a way to move to MySQL or find a new host.

Thanks for the reply and the great software!

you’re not going to like how things work on mysql :slight_smile:

i think changing your host to something that runs software released after 2014 is a much better idea.

e: this got me interested and i’ve pulled postgres 9.1.24 into docker, the aforementioned query works correctly. so you should be fine with software from 2016.

LOL… Thanks, again, for the support and your time.