Tiny Tiny RSS: Community

PHP Warning: Use of undefined constant VERSION - assumed 'VERSION' (this will throw an Error in a future version of PHP)

Running ./update.php --feeds --feedbrowser, I get:

PHP Warning: Use of undefined constant VERSION - assumed 'VERSION' (this will throw an Error in a future version of PHP) in /home/usr/html/www.example.com/public/tt-rss/include/functions.php on line 156

If possible include steps to reproduce the problem:

Run ./update.php --feeds --feedbrowser under PHP 7.2.24-0ubuntu0.18.04.1

tt-rss version (including git commit id):

72d8a34f748

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Ubuntu bionic, PHP 7.2.24, PostgreSQL 10.10.

Please provide any additional information below:

Putting the quotes around VERSION does shut PHP up.

this should help, i think

:+1: That works. Thank you.

I’m getting a similar error message.

Use of undefined constant VERSION - assumed 'VERSION' (this will throw an Error in a future version of PHP)
1. classes/api.php(43): ttrss_error_handler(2, Use of undefined constant VERSION - assumed 'VERSION' (this will throw an Error in a future version of PHP), classes/api.php, 43, Array)
2. api/index.php(79): getVersion()

If possible include steps to reproduce the problem:

not sure when it pops up but it seems like this gets thrown when I use the iOS app

tt-rss version (including git commit id):

5448a9462

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Debian, PHP 7.3.11, PostgreSQL 12.1.

this should fix it, thanks for reporting.

So far so good thanks fox.