Tiny Tiny RSS: Community

No css loaded on main page

Describe the problem you’re having:

the css are not loaded. When I load my page, I have 4 404 errors : tt-rss.css, dijit.css, cdm.css and prefs.css
These files do not exist but the .less files do exist. I never used themes.

tt-rss version (including git commit id):

latest on february 5

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Debian 9.7 / apache 2.4.25 / PHP 7.0.33 / mariadb 10.1.37

i’m not sure wtf you’re doing over there but i’m reasonably certain tt-rss.css is never included anywhere in my source because it is compiled into a different unified stylesheet

so unless you’re requesting this file on purpose manually you shouldn’t get any errors related to tt-rss.css etc

my educated guess would be a server misconfiguration or multiple tt-rss installs conflicting (i.e. git and ancient tt-rss installed from apt) i.e. a pebkac

I’m sure i’m f*cking stupid but nothing changed on my server. It worked for years now. Of course, I can try to load the css manually (what would be the point except an error ?). I’ll try to upgrade myself, the chair, and the keyboard to see if I can’t get better results. By the way, not sure what “themes/default.css:@import “…/css/tt-rss.css”;” mean exactly. I’ll go and learn php and css to find out

theres no more default.css in themes
remove this file and everything will likely start working

its not in the repo so im not sure why it is there for you


How, exactly, did you update? Git pull? Copy? Etc.?

Hi @fox
That did the trick. I have no idea where this default.css come from but it’s a normal install (no .rpm, .deb or whatsoever) from git and git updates

Thanks for the help and advices

Hi @JustAMacUser

I update with this command : git pull origin master


If you run git status it will tell you if there’s any files out of sync with your current checkout. You may want to in case there’s anything else askew. Running git checkout -- . will bring things back to what they should be (though it won’t delete files you added manually).

If ave a few files that appear in red. probably old files : ex :

I didn’t add these files manually. I guess I should delete them anyway. Right ?

Some of those files should be there, some not. I’m not sure why some things are off with your installation. Executable permission bits can cause git to show the files as different but in your case there’s also some files that I don’t think should be there.

If you ran the git checkout command it would make sure the files in the core are correct, an extra css file here or there will literally make no difference. You can delete them if you want, since you’re using git even if you delete an important file you can still get back to what you should have, provided you leave the .git directory alone.

I did some cleanup with the old files. Don’t know why they were not deleted when I did updates. Everything look ok now.