Tiny Tiny RSS: Community

Gitlab is overbloated shit garbage

The more I upgrade it the more hardware it seems to eat, while shitting itself regularly. It’s that bad that I think i have a cron.daily “restart this fucker” script now, and it still doesn’t fix things.

e: removed docker build runner, we’ll see how that goes i guess

e2: literally yandex bot sniffing through the repo brings LA to 6 while gitlab shits itself. fucking ruby garbage.

Ideas? gogs?

1 Like

Gogs seems fine as far as it goes.

Cgit⸮ … :slight_smile:

It’s not much of a solution but does Yandex respect robots.txt? If so, you can at least keep its grubby little fingers out of it.

they do, and i’ve updated the rules, but still it’s a retarded solution

what if like 5 people at once come visit the site oh no gitlab is ded

main problem is the wiki and repo urls, the rest i don’t really need

well maybe pull requests

e: it shit itself again and there’s not even any activity in the logs ffs

e2: and the host where tt-rss.org VM is running shows like 0.5 LA and is generally idle, fuck you gitlab you piece of shit :argh:

     if ($http_user_agent ~* (Yandex)) {
         return 403;


1 Like

+1 for cgit + gitolite, for a lightweight solution. No pull request support though :frowning:

Move the whole thing to TFS, … so many heads exploding just at the idea…



lol i literally clicked “show differences in a PR” and it shit itself and not even front page opened for several minutes

this just isn’t fucking right

e: did a git gc

Gogs is up at https://git.tt-rss.org/ feel free to poke around

I’m going to migrate a few things later today

e: looks like it was actually redis who got insane, i’m loving gogs so far anyway tho

1 Like

Really does look like github, doesn’t it?…

The only thing that might confuse new users is the lack of “bug” tab since we use the forum for those. Maybe add some clearer link to the sticky?

btw there’s gonna be a static index page which is currently at https://git.tt-rss.org/index.html

i could add a Support link to the top bar going to the correct subforum

1 Like

Yeah. that would work.

the plan for the time being is as follows (unless something comes up with gogs)

  • i have migrated all the relevant repos and wiki crap
  • gitlab is going to be removed, primarily because updating it is a retarded adventure for a source build and i’m unwilling to use omnibus / omnibus docker for ~reasons~ (gogs lives in a very nice lightweight docker container)
  • unfortunately i can’t migrate the users so 10 people or so who regularly contribute will have to re-register and be given correct rights
  • i’ll do what i can to keep previous https clone urls working, ssh clone urls for contributors should keep working (?) once gogs is going through system ssh (haven’t tried this yet)

e: SSH clone url is going to change just a bit, fox is replaced with git because gogs is weird and some features are only accessible to “organizations”. can’t do redirects for ssh, lol.

git remote set-url origin [email protected]:git/tt-rss.git


Just tried using the new remote URL as above:

[email protected]:~/rss.gently.org.uk/public/htdocs$ git remote set-url origin [email protected]:git/tt-rss.git
[email protected]:~/rss.gently.org.uk/public/htdocs$ git fetch
Permission denied (publickey).
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

What’s the correct URL?


i’m working on redirects for previous https clone urls

nginx shakes fist

Ah ok. Neither git or https URLs are working for me at the moment.

I’ll wait for things to stabilise :slight_smile:


for SSH clone urls the easiest way is doing something like that

git remote get-url origin | sed s/:fox/:git/ | xargs git remote set-url origin

for i in *; do
	if [ -d "$i" ]; then
		cd $i
		URL=$(git remote get-url origin 2>/dev/null)

		case "$URL" in
			*git.tt-rss.org:fox* )
				URL=$(echo $URL | sed s/:fox/:git/)

				git remote set-url origin "$URL"

		cd ..

yeah redirects are a pain (only got them partially working so far), native gogs urls work fine tho

i.e. [email protected]:git/tt-rss.git and https://git.tt-rss.org/git/tt-rss.git


https clone urls which look like this: https://tt-rss.org/git/tt-rss.git should work now:

working on a few other variants


all other variants i could remember should work now

i.e. /fox/tt-rss.git ; /gitlab/fox/tt-rss.git

note that gogs doesn’t seem to have RSS feeds for everything, too bad i guess

e: tfw you shutdown gitlab and VM suddenly has 3/4 RAM free

For people that might wonder how to update to the new repository, this is what worked for me:

git remote rm origin
git remote add origin https://git.tt-rss.org/git/tt-rss
git branch --set-upstream-to=origin/master master
git up

Nothing earth shattering if you know how to use git… The last command is an alias for "!git remote update -p; git merge --ff-only @{u}" which I find useful.

1 Like

https://tt-rss.org/feeds/ added some barebones rss feeds for repository activity (master branch)


LibXML error 76 at line 307 (column 11): Opening and ending tag mismatch: rss line 1 and channel