Tiny Tiny RSS: Community

Feeds not updating after git pull

So I did a ‘git pull origin master’ Can’t remember when the last time was, but it’s been a while. The update went smoothly as far as I could tell, but now the feeds don’t update anymore. The Fresh Articles page displays a timestamp before the git pull and my update.php process logs “Scheduled 0 feeds to update…” All the subscriptions are there and if I do an OPML export it also has everything in it. I’ve tried restarting the machine. I tried the SIMPLE_UPDATE_MODE to true and then I get new articles, but that is painfully slow.

The complete log for update.php is
Lock: update.lock
Scheduled 0 feeds to update…
Sending digests, batch of max 15 users, headline limit = 1000
All done.
Expired cache/export: removed 0 files.
Expired cache/images: removed 0 files.
Expired cache/js: removed 0 files.
Expired cache/upload: removed 0 files.
Removed 0 old lock files.
Removing old error log entries…
Removing old archived feeds…
Purged 0 orphaned posts.
Removed 0 (feeds) 0 (cats) orphaned counter cache entries.
Sleeping for 120 seconds…

Any thoughts?

  1. read the subforum sticky and fill in missing information.
  2. https://community.tt-rss.org/t/empty-prefs-with-default-profile-feeds-dont-update-having-problems-with-mariadb-come-here/2523/60 ?

I’ve got Centos 7.7 with mariadb 5.5.64 and php 7.2.10

I did a bit more tinkering, I did a debug feed for each individual subscription with forced refetch and rehash. I’ve got all the latest articles. I did then turn off SIMPLE_UPDATE_MODE and restarted the machine. And now the feeds are updating normally :slight_smile:

Wish that I could have done a forced refetch and rehash for all feeds in one go.

this should literally be never needed, and it doesn’t do anything for new articles or feed updates not being scheduled, rehashing is for existing articles only. maybe time went backwards on your server?

I have ntpd running on the server so the time should be OK