Tiny Tiny RSS: Community

Feed label get shifted after being clicked on Chrome

How to reproduce:
Client Chrome / Chromium v80
Server latest TT-RSS from git.

  1. Rename feed by giving long label for example “PHP.net releases AAAAAAAAAAAAAA”
  2. Click on the feed and label will jump to left instead not moving.

Bug is browser related. This behavior does not occur on firefox.

I can confirm this. It only happens with long feed names and only in Chrome.

I’ve been seeing that too. The name doesn’t have to be long, if the left column is narrow that will reproduce the jump. I usually browse with the categories collapsed and never bothered to file a bug.

it seems related to “overflow : hidden; text-overflow : ellipsis” (second rule won’t work without the first one)

unless someone feels its a chrome bug and wants to report this to chrome developers (good luck with that) i can only propose removing the overflow / ellipsis thing since its cosmetic anyway.

This seems to fix it for me … code review? Just use “.dijitTreeRow” selector? What about themes?

/* Fix jumping feed label */
.flat .dijitTree .dijitTreeRow {
	overflow: inherit !important;
}

yeah this should work as a workaround for the time being, alternatively overflow: hidden can be removed from base css

PLEASE READ THIS BEFORE POSTING: Read before posting / reporting bugs

Describe the problem you’re having:
Normally, when clicking on a feed in the left hand pane, the feed opens and displays a list of articles in the right hand pane. Recently, I noticed that feeds with longer titles, will shift all the way to the left of the left pane when clicked. It doesn’t seem to happen all the time, and if I edit the title of the feed down, it seems to stop entirely.

If possible include steps to reproduce the problem:
Change the title of a feed to be lengthy (30+ characters). When there are new articles in the feed, click to open the feed.

tt-rss version (including git commit id):
v20.03-61be0b215

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:
Ubuntu 18.04.2 LTS (GNU/Linux 4.4.0-141-generic x86_64)
postgres (PostgreSQL) 10.10
PHP 7.2.24

Browser is Chrome 80

Please provide any additional information below:
No custom themes, no plugins

the thread discussing this is right there on the front page of this forum

enjoy your two weeks probation