Tiny Tiny RSS: Community

Exceptions while creating PDO objects

A year ago, I had manually installed tt-rss together with fever
My platform is Synology 412+ NAS with DSM 6.2.2-24922, PSP 5.6, MariaDB 5.5.62-0091

tt-rss and fever worked fine for the last year until two days ago it suddenly stopped updating. No changes had been made to my NAS or the software.Today I updated it to version v19.2 (e40c8da). This did not help.

I tried all that I could including replacing the lock file and removing the fever plugin.
I debugged each of my 100 odd RSS feeds from the GUI and all updated manually correctly.

So I turned to the console.
When I ran: /usr/local/bin/php56 /volume1/web/tt-rss/update.php --feeds
I got the following error:

Exception while creating PDO object:SQLSTATE[HY000] [2002] No such file or directory

When I ran any variation of: ./update.php … such as ./update.php --debug-feed http://www.engadget.com/rss.xml --force-refetch --force-rehash | tee debug_output.txt
I got the error:

Exception while creating PDO object:could not find driver

I am at my wits end. I would appreciate any help with this.

  • Fred

why don’t you synology people ever check the rules before posting? anyway, moving to unsupported

Sorry. Thought that the unsupported part was the Synology port of tt-rss, not the Synology platform itself. :man_shrugging: I am using the tt-rss version from github.

Requirements are posted in the wiki:

Everything else, including but not limited to, shared hosting accounts, windows and other alternative OSes, NAS boxes, PaaS services of any kind, alternative web browsers (or old browser versions), is not supported.

My experience is that that is seldom the case. Perhaps your NAS updated itself?

Is it possible PHP’s PostgreSQL extension is not installed? Create a file with phpinfo(); in it and run it
from both the CLI and web.

@JustAMacUser thanks for the response.
I tried this and got a “bad interpreter:Text file busy”. No lsof to kill the process so I had to reboot. :frowning:
I clearly have no knowledge of php.

your problem has nothing to do with tt-rss. go to synology forums or something, fix your broken PHP installation, then everything is going to start working.

Synology did update their php 5.6 package to 5.6.40. This package seem to break the pdo functionality or something else. You have to roll back to version 5.6.39. This worked for me.

Just a gentle reminder that php5.6 might be soon deprecated – it might get fixed for a while on your Synology, but nobody knows how long .
So please do not take the step back to an older (and most likely vulnerable) version of php, instead create a new clean environment with php7 (should be also a package on your Synology).

Thanks for all the suggestions. I’ll give them a try.

@conrad784 Correct, but I couldn’t get it to work again with the clean synology installation with php7 package. Same pdo error for me. Maybe it works for bigonttrss

Ported to PHP7. Same PDO error still.
From what I have learned here, I am guessing that the culprit must be all the current Synology PHP installations. :frowning:

I had the same problem of you guys, on a Syno too.
I just defined DB_HOST to instead of empty in config.php file and everythings working again! :slight_smile:

I had ‘localhost’ until it stopped working. That should be the same as ‘’ AFAIK
As a long shot, I just tried your suggestion. Didn’t help in my case :frowning:

Thanks, you made my day! This was the missing info! Now it is working with version 19.2 on a DSM 6.2.2 with PHP7 & PHP7.2.

Did you change the define in the file config.php of ttrss to:
for php70: define(‘PHP_EXECUTABLE’, ‘/usr/local/bin/php70’);
for php7.2: define(‘PHP_EXECUTABLE’, ‘/usr/local/bin/php70’);


I got it working!!! :slight_smile: But only by switching back to php56. Go figure.

When I wrote earlier that the change to DB_HOST didn’t work I HAD set the PHP_EXECUTABLE correctly to ‘/usr/local/bin/php70’.
Or at least I thought I had. Maybe my editor is doing something funny.

Anyway tt-rss is updating. Maybe I shouldn’t look a gift horse in the mouth :slight_smile:

The fever plugin is no longer letting me log in though. I must have broken something in my efforts to get the updater working. :frowning:

Big thanks to all.

Changes inside TT-RSS broke the Fever plugin awhile go, some users in the community patched it:

I don’t use it so I can speak to whether it still works today, but there’s enough people here (I think) using it that I’m sure it’s probably still working with the appropriate patches.

/usr/local/bin/php72 :wink:

@bigonttrss, weird, I use php72 and everything working so far. :slight_smile:
Maybe a missing plugin in your PHP configuration?

The fever plugin was working with recent tt-rss until my present troubles started.
I was aware of the patch and had applied it.

Fever plugin is running in the tt-rss GUI.

The login is the problem at the moment.

Same problem for me.

Solved by replacing DB_HOST with instead of localhost and switched back to PHP56

Fever is now working again. :slight_smile:
I just deleted it and reinstalled and it started working.