Tiny Tiny RSS: Community

Easy Installer Page Not Rendering Properly

Hello, I am having an issue I need help with. I am new to tt-rss so if you can be specific with your proposed solution that would be very helpful:

When I browse to the tt-rss install page, the webpage does not render properly. All I see is a bunch of code with the occasional drop down. I tried it in Chrome, Firefox, and IE. All with the same result. See attached screenshot.

I cant find the version of tt-rss but I would assume it is the latest version as of 11.14.19, that I got from the clone command in the instructions. Commit ID is 9912f3f
This was installed on Centos 8
PHP 7.2.11
MySQL 8.0.18

Any help would be greatly appreciated. Thanks.

Doesn’t look like your server is actually interpreting the PHP code, instead it’s just printing it out as text.

This isn’t a TT-RSS issue but a web stack issue. You should search the internet (e.g. stackexchange) for steps on setting up a web server with PHP.

If you’re doing this on a new system you should consider using PostgreSQL instead of MySQL. TT-RSS will work a lot better. If you have a need for MySQL (for example, for another application) then MySQL will suffice.

also, preferably in a container.

Pff… In my day we ran bare metal with no firewall… :grin:

(Kidding, of course… Absolutely use a container.)

JustAMacUser, Thanks for pointing me in the right direction. It took a while but I was able to fix it. First I had to edit the /etc/httpd/conf/httpd.conf file by adding “LoadModule php7_module /usr/lib64/httpd/modules/libphp7.so”. Then I had to edit the /etc/httpd/conf.modules.d/00-mpm.conf file by replacing “LoadModule mpm_event_module modules/mod_mpm_event.so” with “LoadModule mpm_prefork_module modules/mod_mpm_prefork.so”. Now the page looks the way its supposed to. Thanks for the help.