Tiny Tiny RSS: Community

Data migration plugin fails silently

After reading this thread I wanted to try the new method of exporting.

  1. If I export to a file, the user is not allowed to write to, the script fails silently, no error is displayed, this might cause confusion for non-experience users.
  2. Can someone quickly explain, why a plugin directory can’t contain “-”? The wiki page tells you to name the folder “data_migration”, but I tried keeping the original git repo name “ttrss-data-migration” and tt-rss is not able to activate this plugin?
  3. As this is replacing import/export, which was available through the web interface, will this plugin be callable via web at some point for users to export their data themselves? – No problem for me currently, this is not a daily problem for my case with very limited amount of users :wink:
  1. i’ll make a note to look at this.
  2. this is how tt-rss class loader works. this naming rule is common for all plugins.
  3. believe it or not, i have thought about this:
  • this plugin can work on datasets of arbitrary size. there’s too many limitations involved with passing possible huge files over http which are commonly enabled by default in php (post body max size, max uploaded file size, etc) to make this work reliably for everyone without tweaking.
  • this kind of migration is not supposed to be a common thing. it’s a special case tool for people who need it.
  • the fact that adding web ui, even for download only, would increase overall complexity significantly for no major gain doesn’t help either.
  1. Thanks for clearing this up, this will be understood by everyone having a look at the plugins folder, but maybe this can be explained in the wiki too? – I would create a merge request, but my limit is 0 :wink: .
  2. :+1: just wanted to know the rationale behind this, most likely this would cause more problems than it would create benefits, yes

i usually post specific clone instructions for the plugin readme files because class names are different and not immediately obvious unless you open init.php.

if you manage to phrase it so an average village idiot would understand, file a PR. i’ve bumped your repo limit on gogs.

this was a case of ZipArchive class in PHP behaving, uh, strangely:

If the directory you are writing or saving into does not have the correct permissions set, you won’t get any error messages and it will look like everything worked fine… except it won’t have changed!
Instead make sure you collect the return value of ZipArchive::close(). If it is false… it didn’t work.

:face_with_raised_eyebrow: