Tiny Tiny RSS: Community

Can't subscribe to ZDI feed

Describe the problem you’re having:
When trying to subscribe to the zero day initiative blog feed ttrss always says that to url doesn’t contain a newsfeed.

If possible include steps to reproduce the problem:
Try to subscribe to the zero day initiative blog feed

tt-rss version (including git commit id):
latest git master

Platform (i.e. Linux distro, PHP, PostgreSQL, etc) versions:

Please provide any additional information below:

Check the feed link:


Please follow pinned post and get other info.

1 Like

Guys, cool down.

I don’t know if Heiko tried it, but myfeedsucks says the feed is ok, however, subscribing in tt-rss does not work.

this feed has literal <html> starting element in its contents so it gets flagged as possible html content and you can’t subscribe because it doesn’t contain any feeds (because it is a feed)

<html xmlns:o="urn:schemas-microsoft-com:office:office" xmlns="http://www.w3.org/TR/REC-html40" xmlns:x="urn:schemas-microsoft-com:office:excel">

<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
<meta name="ProgId" content="Excel.Sheet">
<meta name="Generator" content="Microsoft Excel 15">
<link rel="File-List" href="2019_PatchTable.fld/filelist.xml">


<body vlink="#954F72" link="#0563C1" class="xl65">

et cetera, et cetera.

i have no idea if its technically broken to do shit like that but it’s still really stupid. article content is supposed to be a partial document not this horrible microsoft office garbage dump with meta tags included.

anyway, i’m not going to add further hacks because of people who put shit like that in rss feeds, so as a workaround i suggest using batch subscribe (in preferences -> feeds) which doesn’t do any validation and would simply subscribe you to the feed.

e: i guess tt-rss should require text/html response content type when checking for html content, i’m sure that would break at least one dumbfuck blog out there but at least it would be more technically correct. i’ll think about it.

e2: done https://git.tt-rss.org/fox/tt-rss/commit/de713035fd96684cf8817b8cf0e5a980690ca260

I don’t know if Heiko tried it, but myfeedsucks says the feed is ok, however , subscribing in tt-rss does not work.

Yeah, I’m three months behind on updates (848bb65), that’s why subscribing to that feed worked for me I guess.