Tiny Tiny RSS: Community

Can't Subscribe to Feed(AnandTech) / HTTP/1.1 403 Forbidden

Hello.

I seem to be unable to subscribe to the feed of AnandTech. Upon trying, I get the following error and can’t go past it.

Couldn’t download the specified URL: HTTP/1.1 403 Forbidden

Here is my system:

  • CentOS Linux release 7.7.1908 (Core) on a VPS (DigitalOcean Droplet),
  • 5.5.64-MariaDB MariaDB Server (I know the requirements prefer PostgreSQL but at the time, I had a running MariaDB setup and didn’t want to change it),
  • PHP 7.2.27 (cli) (built: Jan 22 2020 09:31:55) ( NTS ),
  • I’m on the last commit of Mon Jan 27 15:45:04 2020 +0300 of TT-RSS .

I’ve ran the feed through fakecake and it reports that the feed was parsed successfully.

I would post other logs as well but since I can’t subscribe to the feed, I can’t get any.

Moreover, I’ve tried adding the AnandTech feed to my Feedbin account and it worked without any problems.

Previously, I’ve discussed this with the site editors, they peeked some interest but than I haven’t heard back from them. My curiosity is that is this related to TT-RSS or not? Because it seems that I’m the only one having this issue.

Thanks.

That feed fully works for me. Both with curl and adding it to my tt-rss ( 47135160d1fd84e88ebfeb9400ca7ac8c965c39c ) . I’d assume you’ve managed to trip some rate limit on Anandtech’s servers.

Confirming.

Could be but this is the exact same behaviour since the first time I’ve tried to add this feed to my TT-RSS.

Is there any chance that there could be a configuration issue from my side?

Well, see if you can just fetch the feed directly, outside of tt-rss:

curl --verbose https://www.anandtech.com/rss/ 2>&1 | less

or wget if you prefer of course.

Here is the full output of the above curl command on my system. Basically, it fails to retireve the URL.

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
^M  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0* About to connect() to www.anandtech.com port 443 (#0)
*   Trying 104.108.53.171...
* Connected to www.anandtech.com (104.108.53.171) port 443 (#0)
* Initializing NSS with certpath: sql:/etc/pki/nssdb
*   CAfile: /etc/pki/tls/certs/ca-bundle.crt
  CApath: none
* SSL connection using TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384
* Server certificate:
*       subject: CN=www.purch.com,OU=IT,O=Purch,L=Ogden,ST=Utah,C=US
*       start date: Dec 10 00:00:00 2019 GMT
*       expire date: Dec 09 12:00:00 2020 GMT
*       common name: www.purch.com
*       issuer: CN=DigiCert SHA2 Secure Server CA,O=DigiCert Inc,C=US
> GET /rss/ HTTP/1.1
> User-Agent: curl/7.29.0
> Host: www.anandtech.com
> Accept: */*
> 
< HTTP/1.1 403 Forbidden
< Server: AkamaiGHost
< Mime-Version: 1.0
< Content-Type: text/html
< Content-Length: 275
< Expires: Sun, 02 Feb 2020 12:34:20 GMT
< Date: Sun, 02 Feb 2020 12:34:20 GMT
< Connection: keep-alive
< Strict-Transport-Security: max-age=3600
< 
{ [data not shown]
^M100   275  100   275    0     0   1241      0 --:--:-- --:--:-- --:--:--  1250
* Connection #0 to host www.anandtech.com left intact
<HTML><HEAD>
<TITLE>Access Denied</TITLE>
</HEAD><BODY>
<H1>Access Denied</H1>
 
You don't have permission to access "http&#58;&#47;&#47;www&#46;anandtech&#46;com&#47;rss&#47;" on this server.<P>
Reference&#32;&#35;18&#46;deb2f748&#46;1580646860&#46;4ea48dfd
</BODY>
</HTML>

I guess TT-RSS isn’t the problem here but I’m baffled as to why my VPS can’t access this URL.

Almost certainly an IP ban then. Maybe you queried more often than their setup likes. Maybe it was someone in an adjacent IP who got an entire block banned. You won’t know unless you ask AnandTech.

Alright, I’ll ask them.

Thanks for pointing me in the right direction.