Tiny Tiny RSS: Community

Cannot run update.php by any means

Hi.

I’ve been racking my brain all day with this error and I can’t get around it. I’m running the latest version of ttrss on a Debian 9 VPS from DigitalOcean. I installed everything correctly, I used the same steps as on my Raspberry PI3(which works flawlessly btw).

Everything is working fine, except I cannot run updates for the feeds in any manner. I tried crontab, daemon, nothing works. I tried manually launching through “php update.php --feeds --quiet”, I tried without “quiet”, I even tried to force them. Nothing works, I receive the same “error” message again and again. It doesn’t even say what’s wrong exactly. It’s vague af. Does anybody have any idea or point me in the right direction?

CACAT

I mean, it literally says: Please don't run this script as root.

Do this:

sudo -u www-data php ./update.php --daemon

Thanks a million for this! It works now.

There’s a Wiki article for this:

And the error message even suggested checking the wiki. Also, the article has examples you can copy/paste for your system. The updater really should be setup as a systemd service on a modern Linux machine.