Tiny Tiny RSS: Community

Cannot load app…

Fairly often (20% of the time?), when I load the forums, I get this error message:

Cannot load app

It looks like you are offline! Please check your network connection and try again. 

From there onwards, any attempts to reload (F5) the forum ends up with that error message provided I stay in that tab. However, I can open the forum just fine in another tab. Clearly, my network in not a yoyo and is just fine so the message is lying.

Any idea?

maybe your isp doesn’t like it? who knows tbh

try pinging discourse.tt-rss.org

Possible but unlikely…

Seems fine … I can paste an mtr report here but if I am the only one experiencing this, the problem is clearly at my end, somewhere.

you can also try connecting via vpn, even some free openvpn relay would work for a test

Possibly OT?

I don’t get an error message in the browser when clicking rss links to the forums but… there is always more ‘lag’ connecting to discourse.tt-rss.org, (and the git commits, too). Usually I connect through a vpn, but just now I disconnected from my vpn, cleared the cache in my browser, restarted browser and connected through my isp. Same result. I questimate connects to discourse.tt-rss.org always take 5-10 seconds longer to load compared to other browsing. Not really an issue for me, just an observation!

why OT? it’s site feedback. i have a VDS in US, here’s a traceroute:

traceroute to discourse.tt-rss.org (, 30 hops max, 60 byte packets
 2  vl913-c5-14-b5-1.pnj1.choopa.net (  22.305 ms  22.480 ms  22.463 ms
 3  vl116-br2.pnj1.choopa.net (  0.158 ms  0.147 ms  0.302 ms
 4  vl24-er2.pnj1.choopa.net (  8.220 ms  0.259 ms  7.993 ms
 5  vl20-er1.pnj1.choopa.net (  1.121 ms nyiix.retn.net (  87.055 ms  87.066 ms
 6  ae1-3.RT.BM.SPB.RU.retn.net (  113.969 ms  113.958 ms nyiix.retn.net (  86.943 ms
 7  ae1-3.RT.BM.SPB.RU.retn.net (  114.084 ms  114.053 ms  114.038 ms
 8  bor57-bb-po7-2ge.spb.cmk.ru (  113.207 ms  113.274 ms  113.240 ms
 9  rub34-bb-po11-2ge.spb.cmk.ru (  114.618 ms bor57-bb-po7-2ge.spb.cmk.ru (  113.273 ms  113.336 ms
10  rub34-bb-po11-2ge.spb.cmk.ru (  120.456 ms  114.751 ms ip-195-182-129-111.clients.cmk.ru (  108.116 ms
11  ip-195-182-129-229.clients.cmk.ru (  114.233 ms  114.087 ms  113.808 ms

site opens just fine for me via openvpn with no perceptive lag (5 seconds? jesus) and no loading errors. fwiw i’m not doing any QoS or whatever so i’m not sure what could cause this on my end.

e: git.tt-rss.org is on the same subnet / ISP. is it also slow for you?

Here’s my trace route, with my company redacted 'cause reasons.

; mtr -r -c 13 discourse.tt-rss.org 
Start: Mon Jan 22 08:29:22 2018
HOST: serval.XXX.co.uk            Loss%   Snt   Last   Avg  Best  Wrst StDev
  1.|-- internetV.XXX.co.uk        0.0%    13    2.2   2.2   1.3   3.6   0.6
  2.|-- gi0-1.XXX.router.enta.     0.0%    13    2.9   2.8   1.6   3.9   0.6
  3.|-- 1362.te0-0-0-1.interxion3  0.0%    13    9.3   9.9   8.7  11.7   0.6
  4.|-- te0-0-0-2.equinix.core.en  0.0%    13   10.9  11.6   9.9  14.2   1.2
  5.|-- te0-0-2-1.telehouse-east3  0.0%    13   10.5  11.2  10.0  14.2   1.0
  6.|-- spb-ivc-cr1.rascom.ru      0.0%    13   28.0  26.7  25.1  30.1   1.3
  7.|-- spb-ivc-cr1.rascom.as2076  0.0%    13   54.9  56.1  54.9  57.2   0.5
  8.|-- 80-64-108-147.rascom.as20  0.0%    13   50.1  50.8  49.7  52.2   0.5
  9.|-- bor57-bb-po7-2ge.spb.cmk.  0.0%    13   53.8  52.7  51.2  55.3   1.1
 10.|-- rub34-bb-po11-2ge.spb.cmk  0.0%    13   53.3  54.2  51.7  58.7   2.2
 11.|-- ip-195-182-129-111.client  0.0%    13   60.9  60.1  59.3  61.2   0.3
 12.|-- ip-195-182-129-229.client  0.0%    13   51.7  52.6  51.6  57.0   1.3

I cannot see anything wrong with it. When I run it continuously, I still get the above error but the packet seem to reach it just fine. Meh.

After a little bit of testing, I can reproduce the original error every time: just try to open the forums on a tab already containing something! WTF Firefox? …

using mozilla shitware
literally why

Google shitware is better?

I am not even going to mention the kid-eating-glue-in-the-corner-from-Microsoft 'cause really.

it is. both are developed by ethically questionable organizations but one is obviously technically superior.

see, shit like this - and it’s not the first time - is why i don’t even have firefox installed anymore. mozilla can go fuck itself, all the syrupy virtue signaling in the world is not going to hide the rotten core of their organization. also, their browser is kinda garbage.

:frowning: At least there is a button to disable it…

Time for you to write a tinytinyBrowser⸮

chrome is fine for me. google is openly sucking my personal data but services are actually useful and come with minimal amounts of bullshit and proselytizing. for more paranoid people there’s ungoogled chromium i guess.

I personally switched to Firefox so I could use ublock origin on Android. Ads on Android have reached a ridiculous level and I couldn’t tolerate it anymore.

on android blocking ads with local vpn like DNS-66 (which is FOSS) is a much better solution imo: browser agnostic, no need for root, can filter apps.

firefox mobile was pretty terrible last time i used it, very slow and the UI was bad. idk if it’s any better now.

I’ve been using Pi-hole on my home network for ad blocking; it uses DNS as well. Works well and is pretty modest on resources. Also has a nice UI.

Browser choice is Safari because of consistency with mobile devices (Apple still doesn’t let iOS users set default apps, which seems ridiculous in 2018). Firefox is the browser I want to like but Chrome is just built better (though I hate Google’s insatiable snooping).

I could not have said it better myself…

How about w3m for the win⸮ No⸮ …

look up mozilla cliqz and mr robot fiasco etc. mozilla has been on an increasingly shady path and it’s only getting worse. at least google is a known evil.

doing this only makes you easier to fingerprint because you stand out so much (while excluding you from 99% websites so i guess it’s a partial success - if you’re not visiting any websites they can’t track you).

It is almost like all major corporations did not give a fuck about the privacy of their users… Who knew⸮

1984 was wrong. It assumed an evil force would put surveillance in our home. Instead, we pay for the privileged.